背景:
数据库版本:11.2.0.3
数据库环境:单实例(生产主库RAC的备库)
原因:在做生产RAC环境的备库时,为使用管理环境干净地无用的redo进行drop操作时报错:ORA-01623
报错:
SQL> alter database drop logfile group 6;
alter database drop logfile group 6
*
ERROR at line 1:
ORA-01623: log 6 is current log for instance rac2(thread 2) - cannot drop
ORA-00312: online log 6 thread 2: '+REDO1/rac/onlinelog/group_6.274.1004176209'
ORA-00312: online log 6 thread 2: '+REDO2/rac/onlinelog/group_6.261.1004176209'
解决方案
SQL> select t.thread#,t.status,t.instance from v$thread t;
THREAD# STATUS INSTANCE
---------- ------ --------------------------------------------------------------------------------
1 OPEN rac1
2 CLOSED rac2
-- 将CLOSED 状态的THREAD# 进行disable
SQL> alter database disable thread 2;
-- 现在就可清除rac2实例在备库的redo组了
SQL> select GROUP#,THREAD#,STATUS from v$log;
GROUP# THREAD# STATUS
------ ------- ---------
1 1 INACTIVE
2 1 INACTIVE
3 1 CURRENT
4 1 INACTIVE
5 1 INACTIVE
6 2 UNUSED
7 2 UNUSED
8 2 UNUSED
9 2 UNUSED
10 2 UNUSED
-- 清理THREAD# = 2的日志组
SQL> alter database drop logfile group 6;
Database altered.
SQL> alter database drop logfile group 7;
Database altered.
SQL> alter database drop logfile group 8;
Database altered.
SQL> alter database drop logfile group 9;
Database altered.
SQL> alter database drop logfile group 10;
Database altered.
-- 清理完成
SQL> select GROUP#,THREAD#,STATUS from v$log;
GROUP# THREAD# STATUS
------ ------- ---------
1 1 INACTIVE
2 1 INACTIVE
3 1 CURRENT
4 1 INACTIVE
5 1 INACTIVE
SQL> select t.thread#,t.status,t.instance from v$thread t;
THREAD# STATUS INSTANCE
---------- ------ ------------------------
1 OPEN rac1
可参照官方文档: ID 2341816.1
文章推荐
|PostgreSQL|URL|
|-|-|-|
|《课程笔记:PostgreSQL深入浅出》之 初识PostgreSQL(一)|https://www.modb.pro/db/475817|
|《课程笔记:PostgreSQL深入浅出》之 PostgreSQL源码安装(二)|https://www.modb.pro/db/475933|
|《课程笔记:PostgreSQL深入浅出》之初始化PostgreSQL(三)|https://www.modb.pro/db/479524|
|《课程笔记:PostgreSQL深入浅出》之PSQL管理工具-常用(四)|https://www.modb.pro/db/479560|
|《课程笔记:PostgreSQL深入浅出》之PSQL管理工具-高级命令(四)|https://www.modb.pro/db/479559|
|《课程笔记:PostgreSQL深入浅出》之内存与进程(五)|https://www.modb.pro/db/489936|
|《课程笔记:PostgreSQL深入浅出》之外存&永久存储(六)|https://www.modb.pro/db/502267|
|Oracle:|URL|
|《Oracle 自动收集统计信息机制》|https://www.modb.pro/db/403670|
|《Oracle_索引重建—优化索引碎片》|https://www.modb.pro/db/399543|
|《DBA_TAB_MODIFICATIONS表的刷新策略测试》|https://www.modb.pro/db/414692|
|《FY_Recover_Data.dbf》|https://www.modb.pro/doc/74682|
|《Oracle RAC 集群迁移文件操作.pdf》|https://www.modb.pro/doc/72985|
|《Oracle Date 字段索引使用测试.dbf》|https://www.modb.pro/doc/72521|
|《Oracle 诊断案例 :因应用死循环导致的CPU过高》|https://www.modb.pro/db/483047|
|《Oracle 慢SQL监控脚本》|https://www.modb.pro/db/479620|
|《Oracle 慢SQL监控测试及监控脚本.pdf》|https://www.modb.pro/doc/76068|
|《Oracle 脚本实现简单的审计功能》|https://www.modb.pro/db/450052|
|《记录一起索引rebuild与收集统计信息的事故》|https://www.modb.pro/db/408934|
|Greenplum:|URL|
|《PL/Java.pdf》|https://www.modb.pro/doc/70867|
|《GP的资源队列.pdf》|https://www.modb.pro/doc/67644|
|《Greenplum psql客户端免交互执行SQL.pdf》|https://www.modb.pro/doc/69806|
欢迎赞赏支持或留言指正




