0

PgBouncer 1.11.0 发布,PostgreSQL 数据库连接池

PgBouncer 1.11.0 已发布,pgbouncer 是 PostgreSQL 的轻量级连接池,支持会话连接池、事务连接池和语句连接池三种模式。


新版本最主要的新功能是支持 SCRAM 身份验证。此版本还增加了对 PostgreSQL 12(GSSENCRequest)中引入的新启动数据包类型的支持,因此建议使用此版本以便更好地体验 PostgreSQL 12 及更高版本。更新内容如下:


特性


      •  添加对客户端和服务器的 SCRAM 身份验证的支持,添加了新的身份验证类型 scram-sha-256

      • 当存储的密码是 md5 时处理 auth_type=password,就像 PostgreSQL 服务器一样 (#129)

      • 添加选项 log_stats (#287)

      • 添加时区以记录时间戳

      • 将 PID 放入日志前缀的[括号]中


修复


      • 修复 OpenSSL 配置测试

      • 使用 auth_user 修复等待时间计算,该 bug 会导致崩溃或报告垃圾值等待时间

      • 处理 PostgreSQL 12 中添加的 GSSENCRequest 数据包,目前它没有出现问题,但还是要避免混淆有关“坏数据包标题”的错误消息


Cleanups

      • 测试套件中的许多改进和几个新测试

      • 修复 Windows 上的几个编译器警告

      • 展开 [users] 部分的文档并添加到示例配置文件 (#330)


全部PgBouncer更新日志:PgBouncer changelog

「喜欢文章,快来给作者赞赏墨值吧」
【版权声明】本文为墨天轮用户原创内容,转载时必须标注文章的来源(墨天轮),文章链接,文章作者等基本信息,否则作者和墨天轮有权追究责任。如果您发现墨天轮中有涉嫌抄袭或者侵权的内容,欢迎发送邮件至:contact@modb.pro进行举报,并提供相关证据,一经查实,墨天轮将立刻删除相关内容。

评论